Qt for Android Automotive Known Issues and Limitations

Known limitations

Qt for Android Automotive at the current stage has the following limitations:

Known issues, bugs, and defects

Listed here, are all known issues, bugs and defects with this patch release.

Issues affecting more than one module

All known issues, bugs, or defects that affect more than one module are listed and described here. Their status will be updated in every release.

Minimum CMake 3.19 required by all modules

The directory structure of Android NDKs changed in version 22 and higher. This was accounted for in CMake versions 3.19 and higher.

Though the Qt framework's current minimum CMake requirement is version 3.16, the version packaged with the current version of Qt in the Qt Online Installer is 3.24.2. You can select the CMake version from those available in your host environment in Qt Creator as shown in the image below:


We need the libffi package, explicitly libffi6, to be installed on a Linux development host environment. This remains true even if a newer version is already available in the system.

You can do this like so:

sudo apt install libffi6

Issues isolated to specific modules

The following API objects are affected by a known issue, bug, or defect. The descriptions and their statuses are maintained in the associated API documentation.

Reporting issues

Please log any issues you may find via by following the instructions at Reporting.

Available under certain Qt licenses.
Find out more.